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Abstract

Three-dimensional printing allows for the production of highly detailed objects through a process known as additive manufacturing. Traditional,
mold-injection methods to create models or parts have several limitations, the most important of which is a difficulty in making highly complex
products in a timely, cost-effective manner.1 However, gradual improvements in three-dimensional printing technology have resulted in both
high-end and economy instruments that are now available for the facile production of customized models.2 These printers have the ability to
extrude high-resolution objects with enough detail to accurately represent in vivo images generated from a preclinical X-ray CT scanner. With
proper data collection, surface rendering, and stereolithographic editing, it is now possible and inexpensive to rapidly produce detailed skeletal
and soft tissue structures from X-ray CT data. Even in the early stages of development, the anatomical models produced by three-dimensional
printing appeal to both educators and researchers who can utilize the technology to improve visualization proficiency. 3, 4 The real benefits
of this method result from the tangible experience a researcher can have with data that cannot be adequately conveyed through a computer
screen. The translation of pre-clinical 3D data to a physical object that is an exact copy of the test subject is a powerful tool for visualization and
communication, especially for relating imaging research to students, or those in other fields. Here, we provide a detailed method for printing
plastic models of bone and organ structures derived from X-ray CT scans utilizing an Albira X-ray CT system in conjunction with PMOD, ImageJ,
Meshlab, Netfabb, and ReplicatorG software packages.

Video Link

The video component of this article can be found at http://www.jove.com/video/50250/

Protocol

1. Animals

1. For the results reported below, one male Lobund-Wistar rat of ten months of age was obtained from the Freimann Life Science Center,
University of Notre Dame (Notre Dame, Indiana, USA). An ex vivo New Zealand White Rabbit (Male, age = 8 weeks) skull sample, preserved
in 10% formalin, was obtained from the laboratory of Prof. Matthew Ravosa, University of Notre Dame.

2. For in vivo imaging, the rat was anesthetized by Isofluorane (2.5% flow rate) with maintenance via a nose-cone system. The animal was
positioned prone in the standard rat bed (M2M Imaging Inc., Cleveland, Ohio) supplied with the Albira image station. Limbs were positioned
lateral from the torso for a uniform CT acquisition.

3. After image acquisition was completed, the rat was removed from the nose cone and returned to the recovery cage until ambulatory.
4. For scans of the rabbit skull, the specimen was placed in the rat bed in a sealed plastic bag containing formalin.

2. Image Acquisition and Reconstruction

1. In Vivo and Ex Vivo Image acquisitions were performed using the Albira CT system (Carestream Molecular Imaging, Woodbridge, CT). The
system was set to scan a bed of 180 mm length by performing three circular scans (600 projections per scan), each with a 65 mm FOV, which
are then stitched together during reconstruction. The X-ray source was set to a current of 400 μA and voltage of 45 kVp, and used a 0.5 mm
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Al filter to harden the beam. Approximate radiation deep dose equivalent for CT settings was 660 mSv, and shallow dose equivalent was
1171 mSv. These doses are over 10-fold lower than reported LD50 values.

2. Images are reconstructed using the FBP (Filtered Back Projection) algorithm via the Albira Suite 5.0 Reconstructor using "Standard"
parameters. These combined acquisition and reconstruction settings produce a final image with .125 mm isotropic voxels, deemed sufficient
for whole animal analysis and 3D printing of anatomical structures.

3. Data Processing

1. Skeletal features from CT scans may be printed from the raw data without segmentation. However, segmentation of soft tissues is required
prior to processing the data for 3D printing. Here we show an example with lung tissue.

1. Open original MicroPET (data format for all modalities on the Albira Imaging System) file
2. Draw a volume of interest (VOI) around the mouse so that all external space is removed.
3. Under the 'VOI Tools' tab select 'Mask Outside Selected VOI' and set the masking value to -1,000 Hounsfield Units (HU, radiodensity

scale for CT), which will effectively set the external space to the CT density value of air.
4. With all the external space removed, under the 'Tools' tab, select 'External,' then click drop down arrow and select 'Segmentation'
5. Set range to -550 to -200 and click 'Ok.'
6. If file is very large, select 'Tools' tab, select 'Reduce,' and run the program
7. Save as an Analyze file

2. Data must first be converted into DICOM format using PMOD (PMOD Technologies LTD, Zurich, Switzerland) analysis software.
1. Open the PMOD Image Processing Software Package.
2. Along the top row, select the View tab.
3. In the lower right hand toolbar, click the downward arrow labeled Database under Load.
4. Select MicroPET for the raw CT data, or Analyze for the segmented lung.
5. Select the appropriate file and click Add to Selected.
6. Click Open.
7. In the lower right hand toolbar, click the upward arrow under Save.
8. From this menu, choose the file type DICOM.
9. Name the file and select Save.
10. Close PMOD.

3. DICOM data contains volumetric density values for each voxel. In order to print this data, it must be processed as a contiguous surface
instead of a volume. ImageJ v1.43u will be used to obtain surface renderings for further processing.

1. Open ImageJ Image Processing Software
2. Select File > Import.
3. Select Image Sequence.
4. Navigate to the file containing the newly created DICOM and select it.
5. Select Plug-ins > 3D > 3D Viewer.
6. Two windows will appear, the 3D viewer will appear and an ADD window.
7. Under Display as in the ADD window change Volume to Surface.
8. Change the default value of Threshold to 210.
9. Click OK.
10. In the 3D Viewer menu bar, select File > Export surfaces as > WaveFront.
11. Name the file and click Save.

4. Two programs, Meshlab v1.3.1 and Netfabb Studio Basic 4.9, will concurrently remove any excess mesh, join together disconnected meshes,
repair holes, and smooth the final mesh. The primary differences between these two programs are the tool sets made available to the user,
and some of the interface navigation control. They are both 3D mesh editing software programs, and their use together provides the easiest
approach to editing the model.
 

 indicates that these actions should be executed in Meshlab v1.3.1
 

 indicates that these actions should be executed in Netfabb Studio Basic 4.9
1. To import meshes into editing software:

1.
Open Meshlab v1.3.1 

2. From the menu bar select File > New Empty Project.
3. Selct File > Import Mesh.
4. Select the file and click Open.
5. Once the file has loaded, a dialogue box will open. Keeping Unify Duplicated Vertices checked, press OK.

1.
Open Netfabb Studio Basic 4.9. 

2. Drag the desired file straight onto the Netfabb Studio Basic screen.

2. To remove unwanted mesh from the surface :
1.

From the menu bar in Meshlab, select Filters > Cleaning and Repairing > Remove Isolated Pieces (WRT Diameter). 
2. Remove isolated connected components whose diameter is smaller than the specified constant. Enter a maximum diameter for

these components and click Apply.
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3. Gradually, increase the maximum diameter to remove bigger pieces. Click Apply after each diameter modification.

3. To join disconnected pieces, holes must be cut in the current meshes at the desired locations of a new bond, and a bridge of mesh
must be built between.

1.
Use the Selection Tool, seventh tool from the left in the menu bar, to select the pieces of mesh that will be cut out. 

2. Delete selected pieces of mesh with the Delete Faces button, the third tool from the left in the menu bar.
3. From the menu bar, select File > Export Mesh As.
4. Name the file and change the file type to STL.
5. Press Save.
6.

A dialogue box with saving options will appear, press OK. 
7. Drag this new file into Netfabb.
8. On the top menu, select Repair, the fourth tool from the left.
9. Select the Add triangles tool, thirteenth from the left.
10. Click on an open edge (they will be yellow) on one side and then click on an open edge on the other piece. Create 5-10 bridges

across the gap.
11. Select the Automatic Repair button at the bottom right
12. Highlight Default Repair.
13. Click Execute.
14. Press Cancel after the repair has been executed.

Optional: Some created triangles may be the wrong orientation. The following steps can be used to reorient these triangles.
1. Select the Flip Selected Triangles Button.
2. Click on any disoriented triangles to rotate all triangles in the correct direction.

4. To repair craters and holes, entire holes and craters must be removed and bridges must be built on each side of the mesh.
1.

Click the Selection Tool. 
2. Select the crater or hole to be filled.
3. Click the Delete Faces button.
4. From the menu bar, select File > Export Mesh As.
5. Name the file and change the file type to STL.
6. Press Save.
7. A dialogue box with saving options will appear, press OK.
8.

Drag this new file into Netfabb. 
9. On the top menu, select Repair, the fourth tool from the left.
10. Select the Add triangles tool, thirteenth from the left.
11. Click on an open edge (they will be yellow) on one side and then click on an open edge on the other piece. Create 5-10 bridges

across the gap.
12. Select the Automatic Repair button at the bottom right
13. Highlight Default Repair.
14. Click Execute.
15. Press Cancel after the repair has been executed.

5. Laplacian smoothing, the smoothing algorithm in Meshlab, is used to smooth the object while still preserving the structural integrity of
the model.

1.
Navigate Filters > Smoothing > Fairing and Deformation > Laplacian Smooth. 

2. Select a number of smoothing iterations. More iterations will result in a smoother model, but each iteration slowly degrades the
volume of the model, which can result in disconnected pieces and sharp edges. 1-5 iterations are recommended.

3. Press OK.
4. From the menu bar, select File > Export Mesh As.
5. Name the file and change the file type to STL.
6. Press Save.
7. A dialogue box with saving options will appear, press OK.
8.

Drag this new file into Netfabb. 
9. On the top menu, select Repair, the fourth tool from the left.
10. Select the Add triangles tool, thirteenth from the left.
11. Click on an open edge (they will be yellow) on one side and then click on an open edge on the other piece. Create 5-10 bridges

across the gap.
12. Select the Automatic Repair button at the bottom right
13. Highlight Default Repair.
14. Click Execute.
15. Press Cancel after the repair has been executed.
16. From the menu bar, select File > Export Mesh As.
17. Name the final file and change the file type to STL.
18. Press Save.
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19. A dialogue box with saving options will appear, press OK.

4. Printing

1. Printing using the Makerbot
1. Open the STL file in ReplicatorG. ReplicatorG is a Makerbot Industries program used to communicate with the Makerbot.
2. Click Scale from the lower right hand corner menu and select Fill the Build Space!
3. Select Rotate and click Lay Flat.
4. Click Center.
5. For models with fine detail, select fill build platform to scale up model.
6. From the same menu, click Move and select Put on Platform.
7. Once the proper orientation has been achieved, select Generate GCODE from the top menu bar.

 

*A window with printing options will appear.
8. Select the extruder that will provide the filament to print the object (Left or Right).
9. Select Use Raft/Support.
10. From the drop down menu entitled Use support material, select Full Support.
11. Select Generate GCODE. A pop-up box showing the progress of the GCODE will appear.
12. Once the GCODE has been completed, select Build to file for use with SD card.
13. Click Save.
14. Drag the file onto an SD card.
15. Place the SD card into the Makerbot and using the Makerbot keypad select Print from SD.
16. Under Print from SD, select the desired file name. The Makerbot will automatically begin to warm-up to print the object.

2. Shapeways Printing
1. After creating a free account with Shapeways, the STL file can be directly uploaded to the Shapeways website: http://

www.shapeways.com/upload/
2. Click Upload and select the STL file.
3. Select a Title for the uploaded file.
4. Select a Unit of Measure from the dropdown menu.
5. Click Upload Model.
6. The file is now ready for printing through Shapeways. Once the file is uploaded Shapeways will take a few minutes to process the file to

be sure it can actually be printed. You will be able to print the model from the "my models" page after about ten minutes.
7. The "white strong flexible" selection was used to print skeletal structures, while "purple strong flexible" was used for lung tissue.

3. ProJet HD 3000 Printing
1. The STL file may also be printed out using a commercial high-resolution three-dimensional printer like the ProJet HD 3000

(Springboard Engineering Solutions LLC, Innovation Park, Notre Dame, IN, USA).
2. The STL file is loaded into the 3D Systems proprietary software to layout the job on the platform. This requires changing the orientation

of the model around to minimize the use of wax support and print time. This file is saved.
3. The job is then electronically sent to the printer.
4. A platform of aluminum is loaded into the printer and the ProJet HD 3000 begins to print the object.
5. The model is then removed from the platform and placed into an oven at approximately 73 °C to melt the support wax from the model.
6. The object is removed hot and wiped down with a Kimwipe to remove remaining surface wax.

Representative Results

 

Figure 1. 3D printed models of the lungs and skeletal features of a rat X-ray CT data set.  Objects were printed using a ProJet HD 3000
(left), Shapeways Inc. (Center) or a Makerbot Replicator (right). The scale bar denotes 2 cm. Note that the scale bar in panel C is smaller than
that of A and B, which reflects that in some cases the Makerbot must print an enlarged object in order to output sufficient detail.

Figure 1 depicts the final products for three methods of printing of the same in vivo rat CT data set. All three models consist of a cropped skeletal
structure and removable lungs which were printed independently and pieced together. The model at left is the result of the ProJet HD 3000 high-
resolution printer, created using translucent acrylic plastic. The object at center was produced using a third party company, Shapeways Inc., in
which the skeletal structure was printed using nylon 12 white plastic while the respiratory structures were fabricated in purple. These first two
models were printed to actual scale, measuring approximately 11 cm in length. The object at right was made using the MakerBot. The skeletal
structure was printed using natural colored ABS (acrylonitrile butadiene styrene) plastic and the lungs with lime green ABS. Because of the
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resolution limits of the MakerBot, this model could not be printed to scale without degradation of fine structure like the rib cage. Instead, the
model was scaled up by almost 2X using the "fill build space" option to obtain the desired visual detail, resulting in an object of 21 cm in length.

 

Figure 2. 3D printed models of a an ex vivo rabbit skull data set.  The objects displayed were printed using a ProJet HD 3000 (left),
Shapeways Inc. (Center) and a Makerbot Replicator (right). The scale bar denotes 1 cm.

Figure 2 shows the final products of each method of printing for the ex vivo rabbit skull CT data set. The model at left is the result from the
ProJet HD 3000 high-resolution printer using translucent acrylic plastic. The model at center was printed in white nylon12 plastic through
Shapeways Printing. The object at right was printed in white plastic using the MakerBot. All three objects were printed to scale and measure
approximately 8.5 cm in length.

 

Figure 3. 3D printed models of a full rat X-ray CT data set. Objects were printed using a ProJet HD 3000 (left), and Shapeways Inc. (right).
The scale bar denotes 1 cm.

Figure 3 depicts the final products for two methods of printing of a full in vivo CT data set of a rat. Both models consist of a complete skeletal
structure (minus the tail) and removable lungs. The model at left is the resultant of a high-resolution printer, the ProJet HD 3000, printed using
translucent acrylic plastic. The model on the right was printed using Shapeways Printing, with the skeletal structure created using white nylon12
plastic and the lungs in purple. These two models were printed to actual scale, measuring approximately 19 cm in length. Because of the
intricate detail required, the full skeleton could not be printed with the MakerBot Replicator.

During the exploration of three-dimensional printing techniques, certain advantages and disadvantages were observed and are outlined in Table
1.

Method of Printing Advantages Disadvantages

MakerBot Extremely fast, variety of color options, able to
print in two colors, extremely inexpensive

Lowest level of detail. Removal of support
materials is slow (on the order of a couple
hours).

Shapeways Varity of color options, variety of materials
for printing, high level of detail, relatively
inexpensive

Two-week time to process and receive an order

ProJet HD 3000 Relatively quick turnaround, highest level of
detail, high throughput, easy to remove support
materials (wax).

Most expensive up front cost, only one color
option during practical use.

Table 1. Comparison of 3D printing technologies available to print CT data sets.

Discussion

X-ray CT data sets of a living Lobund-Wistar rat and an ex vivo New Zealand White Rabbit skull were utilized to demonstrate the feasibility of 3D
object production from pre-clinical biological data. Models were generated using three difference sources: 1)The popular Makerbot Replicator,
2) The third party company Shapeways Inc, and 3) The high-grade commercial ProJet HD 3000. Each printer was able to generate objects that
satisfied the principle goal of enhanced data visualization.

During the process of printing pre-clinical CT data, the advantages and disadvantages of each method of printing were ascertained and
summarized for the end user. The MakerBot Replicator is an inexpensive ($1,750) bench top solution that is accessible to virtually any lab
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around the globe. It can print in multiple colors with inexpensive inputs (a rat CT with lungs used about $3.50 in plastic). However, the Makerbot
is limited by resolution, and thus some models will have to be enlarged for proper extrusion and visualization of intended structure. Shapeways
Inc. provides an outstanding number of selections with regard to color and material. The models are high resolution, and robust. While their
prices are about 10-fold higher than the MakerBot on a per unit basis (a rat CT with lungs was $41.61), a user can execute a limited number
of jobs and avoid the upfront cost of purchasing a printer. The two-week lead time from Shapeways is a minor disadvantage. The ProJet HD
3000 provided outstanding models in terms of resolution and strength. We were fortunate enough to contract the printing of our objects on the
ProJet HD 3000 at Innovation Park at Notre Dame (about $30 for a rat CT with lungs for labor and materials). Users may have difficulty with
access to this type of equipment as they are priced in the range of $80,000, and it is cumbersome to print with multiple colors as well. Since
each instrument/manufacturer provides a different metric to describe the resolution for object printing (Shapeways minimum level of detail = 0.2
mm, minimum wall thickness = 0.7 mm, 5 MakerBot slice thickness = 0.2-0.3 mm with a 0.4 mm nozzle, 6ProJet HD 3000 DPI = 656 x 656 x 800
with an accuracy of 0.025-0.05 mm ), a qualitative assessment of relative resolutions between each system suggests that both Shapeways and
the ProJet HD system can print in high detail to scale, while some objects must be enlarged for successful use of the MakerBot. Collectively, all
three methods are environmentally friendly and provide a convenient means to achieve facile production of highly detailed pre-clinical X-ray CT
models.

Conclusion

Gradually, the technology of 3D printing has become more accessible as both costs and complexity have been minimized.8, 9 Now, literally
anyone may print high-resolution, three-dimensional objects from digital files. These detailed three-dimensional objects can be useful tools
for both educators and researchers alike. Furthermore, they provide a means of visual communication that assists in achieving a clearer
understanding.10 For example, medical researchers can use specimen or patient-specific models to improve both communication and
comprehension with their colleagues and patients.11 Although representation on 2D screens has come a long way, there is absolutely no
replacement for the visual and sensory experience of holding a real object that is able to be held, rotated, examined and moved around. A
model paired with an electronic data representation is even more powerful as it allows researchers to examine the physical object for regions
of interest, and to find those areas on a computer model for further quantitative analysis. With proper data collection, surface rendering, and
stereolithographic editing, it is possible to rapidly produce detailed, relatively inexpensive models from X-ray CT data. Here, we provide a
detailed, step by step method for the production of a three-dimensional model from pre-clinical small animal data collected with an X-ray micro-
CT. We acquired our in vivo and ex vivo CT data sets using an Albira image station, and performed subsequent processing with PMOD, ImageJ,
Meshlab and Netfabb software packages. Finally, we provide detailed instructions to enable three-dimensional model printing with a range
of commercial solutions. In each case, the end result is a model that provides a unique, hand-held, physical manifestation of the acquired
tomographic data that would normally be restricted to a computer screen.
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