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SUMMARY

Optical slice microscopy is commonly used to characterize themorphometric fea-
tures of 3D cellular cultures, such as in vitro vascularization. However, the quan-
titative analysis of those structures is often performed on a single 2D maximum
intensity projection image, limiting the accuracy of data obtained from 3D cul-
tures. Here, we present a protocol for the quantitative analysis of z stack images,
utilizing Fiji, Amira, and WinFiber3D. This protocol facilitates the in-depth exam-
ination of vascular-like structures within 3D cell culture models.
For complete details on the use and execution of this protocol, please refer to
Koch et al. (2020).
BEFORE YOU BEGIN

Note: This protocol is an image analysis protocol. The presence of z stack confocal images is

assumed. The presented steps were performed on a nd2 image sample data set with the

following resolution: x/y resolution of 0.8123 px/mm; x/y size of 1,024 px or 1,260.6828 mm;

x/y pixel size: 1.23 mm/px; total z-size of 452.5 mm with a step size of 2.5 mm per slice; z reso-

lution of 0.4 px/mm; and voxel size x/y/z: 1.23 x 1.23 x 2.5 mm3/voxel.

Other image data sets can be used and the relevant information input at various stages of the pro-

tocol. An example image and the output of the intermediate steps is provided so that the user can

follow the steps (see Supplementary Material; available at https://data.mendeley.com/datasets/

btrrwrmt7z/1).

To ensure correct quantification of structures, high quality 3D images need to be obtained. Accord-

ing to the Nyquist Theorem (Nyquist, 1928), the sample rate should be more than 23 of the size of

the smallest features. Moreover, the numerical aperture of the objective determines the spatial
STAR Protocols 1, 100180, December 18, 2020 ª 2020 The Authors.
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Figure 1. Convert Raw Image Data into Tiff Files Using Fiji

Screenshot of importing a nd2 file into Fiji (A) and viewing the voxel size and other metadata from the image file (B).
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resolution with the smallest resolvable details being approximately (l – emission wavelength). This

protocol has been designed to minimize noise and artifacts in the raw image. However, an adequate

signal-to-noise ratio is crucial for a close representation of the sample. While some noise in the lower

slices can be accounted for (see Troubleshooting 1), a z stack with extensive background noise and/

or artifacts might not be suitable to use for quantification purposes. Further introductory information

on image processing principles can be found in Soille (2003) and Russ and Neal (2016).

Ensure that imaging parameters used on the samples of interest are appropriately recorded. Infor-

mation on how to access the meta data of the images used is described below.

Note: We have provided here a step-by-step manual protocol for image analysis modified

from Krishnan et al. (2008) and expanded upon. The protocol relies on Fiji, WinFiber3D,

and Amira (see Key Resources Table). Amira is a proprietary software package (available

from Thermo Fisher Scientific). In order to facilitate automated image analysis, Tcl and Python

scripts were developed. See the Limitations section below. The timing information provided is

based on 1GB nd2-file processed on an Intel Core i7-6700 with 16.0 GB RAMmachine running

a Windows 10 (64-bit) operation system.

Convert Raw Image Data into Tiff Files

Timing: ~60 s per file with Fiji

Multi-dimensional microscopy images can be acquired on a variety of imaging platforms. The raw

image data and the associated meta data are saved in proprietary file formats. These formats can

be converted into an open standard, the Open Microscopy Environment (OME)-TIFF format, using

the Bioformats software tool (Linkert et al., 2010). This tool is available for a variety of image analysis

software, for example Fiji (Schindelin et al., 2012). To ensure the correct measurement of the struc-

tures, the voxel size needs to be provided in later steps to Amira. If the voxel size of the image was

not noted down during image acquisition, it needs to be done in this step (Figure 1). Alternatively,

additional software extensions can be purchased for Amira. The XBioFormats extension allows for

loading a variety of vendor formats directly into Amira.

1. Open the microscopy image file in Fiji

a. Either use ‘‘File’’ -> ‘‘Open’’ and choose the file;

b. Or drag-and-drop the file into the Fiji window.
2 STAR Protocols 1, 100180, December 18, 2020
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2. Read out the voxel size using ‘‘Image’’ -> ‘‘Show Info’’ or press Ctrl + I and note it down.

3. Use ‘‘File’’ -> ‘‘Save as’’ -> ‘‘Tiff.’’ to save the image as a tiff file.

CRITICAL: In the later steps, Amira does not read the metadata of tiff files. Therefore, the
manual input of the correct voxel size is essential for the accurate output of the measure-

ments. If the size of the image was not noted down during the acquisition, it can be read

from themeta data in this step. In cases where the image size is unknown, the output of the

last step must be read in pixels and not in metric units.
KEY RESOURCES TABLE
REAGENT or RESOURCE SOURCE IDENTIFIER

Software and Algorithms

Fiji-ImageJ V1.52p Schindelin et al., 2012 https://imagej.net/Fiji

Amira V2020.1 Stalling, Westerhoff and Hege,
2005

https://www.fei-software-center.com/
forms/amira-trial/

WinFiber 3D V1.0 N/A https://mrl.sci.utah.edu/software/
winfiber3d/

Tcl and Python scripts for automated
image analysis

This paper https://github.com/theia-dev/acvq
STEP-BY-STEP METHOD DETAILS

Correct Intensity Attenuation

Timing: ~30 s per file with Amira

In 3D microscopic images, the average intensity in lower slices (i.e., further away from the objective)

can be decreased by light absorption in other slices. This intensity attenuation is corrected for using

the CORRECT-Z-DROP module in Amira by fitting an exponential curve to the average intensities in each

of the slices. The automatic mode uses with an automatic best fit of a and b, u specifies the slice num-

ber scaled between 0 and 1.

1. Start Amira and open the converted tiff file (Figure 2A). The Project view will open, and an ORTHO

SLICE module will be attached automatically (Figure 2B).

a. Either use the ‘‘Open Data’’ Button;

b. or click on ‘‘File’’ -> ‘‘Open Data.’’ and select the image.

Note: Here you enter the voxel size as obtained from the image metadata (Figure 1).

2. Attach the CORRECT-Z-DROP module by right-clicking on the input data (tiff file) (Figure 2C).

a. Either using the search box;

b. or click on ‘‘Image Processing’’ -> ‘‘Grayscale Transforms’’ -> ‘‘Correct Z Drop’’ and click

‘‘Create.’’

3. Click on the CORRECT-Z-DROP module to open the Preference view and adjust the settings

(Figure 2D):

a. The Automatic mode is ticked by default. This can be changed to a user-defined expression if

appropriate.

4. Click on ‘‘Apply’’ to use the module (Figure 2E).
STAR Protocols 1, 100180, December 18, 2020 3

https://imagej.net/Fiji
https://www.fei-software-center.com/forms/amira-trial/
https://www.fei-software-center.com/forms/amira-trial/
https://mrl.sci.utah.edu/software/winfiber3d/
https://mrl.sci.utah.edu/software/winfiber3d/
https://github.com/theia-dev/acvq


Figure 2. Open the Image File in Amira and Correct the Intensity Attenuation

Import the tiff file into Amira and provide the voxel size (A). The Project view opens automatically, and an ORTHO SLICE module is attached (B). Attach the

CORRECT Z DROP module by right-clicking on the input data and either use the menu (left) or the search bar (right) (C). Adjust the settings in the properties

window (D; lower left field). A new [filename].corrected object is created (E).
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Noise Reduction and Smoothing

Timing: ~70 s per file with Amira

Before applying a threshold to the image to detect the edges of the features, the noise is reduced,

and potential artifacts are removed. Amedian filter is applied to remove the ‘‘salt and pepper’’ noise

from the image. This is followed by a Gaussian blur to smooth the boundaries of the features.

5. Open the Console in Amira.
4

a. Either by clicking ‘‘Window’’ -> ‘‘Consoles’’;

b. or by clicking on the console button on the lower right corner of the Amira window;

c. or with the shortcut Ctrl + Alt + A.
6. Type: create ‘‘HxlmageFilters’’ and press the enter key.
STAR Protocols 1, 100180, December 18, 2020



Figure 3. Noise Reduction and Smoothing in Amira

Use the console to create the IMAGE FILTERS module (A, lower right panel), select a median filter and adjust the settings (A, lower left panel). Repeat the

steps and select a Gaussian smoothing (B).
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a. A module called WRAPPER: IMAGE FILTERS will be created in the Project view.
7. Click on the WRAPPER: IMAGE FILTERS module to open the Preference view and adjust the settings

(Figure 3A):
a. Select the [filename].corrected object as the Data Source.

b. Filter: Smoothing: Median; 3D.

c. The Kernel size determines the size of the pixel mask, meaning the area to be sampled when

calculating the median. Here, a kernel size of 3, equating to a 3 3 3 3 3 pixel mask in 3D is

applied.
8. Click on ‘‘Apply’’ and the filtered object will be created in the Project View.

9. Repeat step 6 to create a second WRAPPER: IMAGE FILTERS module for the Gaussian blur.

10. Click on the WRAPPER: IMAGE FILTERS 2 module to open the Preference view and adjust the settings

(Figure 3B):
a. Select the [filename]-filtered object as the Data Source.

b. Filter: Smoothing: Gaussian; 3D.

c. A Kernel size of 33 33 3 is applied for next neighbor detection. The ‘‘Sigma Rel’’ field allows

the adjustment of the width of the Gauss function relative to the kernel size. Set the sigma to 1

in x, y, and z and observe the outcome to ensure all key objects are visible without artifacts.

Adjust if necessary.

Note: There are two Consoles in Amira, for Tcl and for Python commands. We used the Tcl

Console.

CRITICAL: For both filters, the kernel size is chosen to cover immediate neighbors. The
relative sigma might be adjusted for images with varying noise levels. The outcome can

be visualized in Amira by attaching an ORTHO SLICE module: ‘‘Display’’ -> ‘‘Ortho Slice’’ or

by attaching an IMAGE ORTHO PROJECTIONS module: ‘‘Display’’ -> ‘‘Image Ortho Projections’’

to view a 2D projection of the image stack.
Deconvolution

Timing: ~180 s per file with Amira

Deconvolution removes the out-of-focus light present in 3D images. The light diffraction can be

characterized by a point spread function (PSF) which is utilized to correct for the distortions and

reverse the effects of the out-of-focus light. The PSF can be generated for an experimental set up

using a fluorescent bead or created theoretically using known algorithms. We utilize the Amira
STAR Protocols 1, 100180, December 18, 2020 5



Figure 4. Deconvolution Using Amira

Attach the DECONVOLUTION module and adjust the settings in the Properties view (A). After applying the deconvolution algorithm, export the

[filename].deconv file as a tiff file (B). The number of iterations effects the outcome of the deconvolution on the y/z axis (C) and the x/y axis (D).

ll
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DECONVOLUTION module to compute the PSF and apply a non-blind iterative maximum-likelihood de-

convolution algorithm to the data.

11. Create the DECONVOLUTION module by right-clicking on the filtered-filtered object.
6

a. Either using the search box;

b. or ‘‘Image Processing’’ -> ‘‘Frequency Domain’’ -> ‘‘Deconvolution’’ and click ‘‘Create.’’
12. Click on the DECONVOLUTION module to open the Preference view and adjust the settings (Fig-

ure 4A):
a. The first set of settings determines the parameters for the deconvolution algorithm. To

reduce boundary artifacts at the top and bottom (z plane), we chose a border width of

0 in x, 0 in y, and 75 in z with 20 iterations. A constant initial estimate, fixed overrelaxation

and no intensity-based regularization and a standard (non-blind) deconvolution method

will work for most images. Further information on those settings can be found in the Amira

help.

b. The parameters for the point spread function are derived from the numerical aperture of the

objective (NA, 0.45), the wavelength of the transmitted light (p, 0.52; an Alexa-488 fluoro-

phore was used in the sample data) and the refractive index of the specimen (n, 1.333; the

hydrogel has a similar refractive index as water). The mode was set to confocal. Adjust the

settings to be relevant for your image. Alternatively, use the EXTRACT POINT SPREAD FUNCTION

to obtain a point spread function from an imaged bead.
13. Two new objects are created, the point spread function ([filename].psf) and the deconvoluted

image ([filename].deconv).

14. Export the deconvoluted image by clicking on the [filename].deconv object in the Project view

and choose ‘‘File’’ -> ‘‘Export Data As.’’ Change the file type to ‘‘3D Tiff (*.tif)’’ (Figure 4B).
STAR Protocols 1, 100180, December 18, 2020



Figure 5. Binarization of the Image in Fiji

Open the deconvoluted images (A) and open the AUTO THRESHOLD module (B). Set the properties in the settings window (C) and apply the module. A

binarized (black and white) image is the result (D).
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Note: The border width setting reduces potential deconvolution artifacts at the boundaries of

the image. For our sample data set, we observed artifacts in z but not in x, and y. For perfor-

mance reasons, it is advisable to choose the border width such that the sum of the size of the

input data set and the border width value results in a power of two. For the example image, the

border width in x, y was chosen to be 0 as 0 + 1024 = 1024 equals to 210, and in z 75+ 181 =

265equals to 28.

The number of iterations determines the output and is closely linked to the computing time. For our

sample data the changes between 5 and 100 iterations were minor (Figures 4C and 4D). We selected

20 as a good compromise for improvement versus computing time.
STAR Protocols 1, 100180, December 18, 2020 7



Figure 6. Labeling and Removal of Small Fragments in Amira

The MULTI-THRESHOLDING module is used to label the black (0) pixels as exterior (A). A 3D model can be rendered in the Segmentation View (B). Small

particles are removed using the REMOVE ISLANDS function in Amira (C).
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Binarization

Timing: ~30 s per file with Fiji

The image is binarized in Fiji using the Otsu method. The ‘‘Stack’’ option needs to be ticked in order

to process all slices of one stack.

15. Open the deconvoluted tiff image in Fiji (Figure 5A).
8

a. Either use ‘‘File’’ -> ‘‘Open’’ and select the file;

b. or drag-and-drop the file into the Fiji window.
16. Press ‘‘Image’’ -> ‘‘Adjust’’ -> ‘‘Auto Threshold’’ (Figure 5B).

17. Select ‘‘Otsu’’ as the thresholdingmethod and tick the following options: ‘‘Ignore black,’’ ‘‘White

objects on black background’’ and ‘‘Stack’’ (Figures 5C and 5D).

18. Save the binarized image ‘‘File’’ -> ‘‘Save as’’ -> ‘‘Tiff..’’
STAR Protocols 1, 100180, December 18, 2020



Figure 7. Distance Mapping and Thinning in Amira

Use a CHAMFER DISTANCE MAP module (A) and a THINNER module (B) to skeletonize the image.
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Note: In images with a large intensity attenuation, the slices furthest away from the objective

might be faint, even after intensity correction. That can lead to noise during binarization. See

Troubleshooting 1. Use ‘‘Image’’ -> ‘‘Stacks’’ -> ‘‘Z Project’’ to visualize the outcome of the

thresholding on a 2D projection. The thresholding method might be adjusted for various im-

ages. As an alternative to Fiji, the XImagePAQ extension for Amira includes an Auto Thresh-

olding module which might be used instead.
Labeling and Removal of Small Fragments

Timing: ~45 s per file with Amira

Back in Amira, the multi-thresholding module is used to label the binary image for further processing

in Amira. The exterior region is set to 0, so that all voxels with ‘‘1’’ will be labeled as interior.

To remove small fragments which are not of interest, the REMOVE ISLAND function is applied.

19. Open the binarized image in Amira (see step 1 for details).

20. Attach the MULTI-THRESHOLDING module by right-clicking on the binarized input object.
a. Either using the search box;

b. or ‘‘Image Segmentation’’ -> ‘‘Multi-Thresholding’’ and click ‘‘Create.’’
21. Click on the MULTI-THRESHOLDING module to open the Preference view and adjust the settings

(Figure 6A):
a. Set the Exterior-Inside value to 0. Thereby all pixels with value 0 (black) are labeled as exte-

rior. Click ‘‘Apply’’ and a [filename].labels object is created.
22. Switch to the Segmentation view (Figure 6B).
a. Select the binarized input image as Image source and the [filename].labels object as Label

field.

b. Switch on the two-viewer panel.

c. Check the box at Inside 3D to view a 3D model of the data.
23. ‘‘Segmentation’’ -> ‘‘Remove Islands’’ (Figure 6C).
a. Select a size filter (in voxel) in the dialog box. A pictogram explains the neighbor merging

function. The ‘‘Highlight all islands’’ button can be used to preview the islands in the Segmen-

tation viewer. Click ‘‘Apply’’ and close the dialog box when finished. For our sample image,

we used 159 voxel (600 mm3; 600 mm3/1.233.1.233 2.5 mm3/voxel) as a cut-off and merging

if the border exceeded 25% of the perimeter, applied to 3D.
STAR Protocols 1, 100180, December 18, 2020 9



Figure 8. Convert to Spatial Graph and Compute Thickness in Amira

Attach a TRACE LINES module to convert the thinned image into a Spatial Graph object (A) and use the SMOOTH LINE SET module (B). Calculate the thickness

information with the EVAL ON LINES module (C) and export the spatial graph object as an .mv3d file (D).

ll
OPEN ACCESS Protocol
Note: Rendering the 3Dmodel and highlighting islands requires a high-end graphics card and

might not be feasible on all machines. Also, the manual removal of fragments in this view is

possible.

The size of the ‘‘islands’’ has to be provided in voxel.
Distance Mapping and Thinning

Timing: ~20 s per file with Amira

The distance mapping step labels each pixel with the distances to its boundary pixels to determine

the separation of points. The THINNER module takes the segmented objects and removes voxel by

voxel until a skeleton of connected voxels remains.

24. Switch back to the Projects view and right click on the [filename].labels object and right click to

attach a CHAMFER DISTANCE MAP module by:
10
a. either using the search box;

b. or ‘‘Image Processing’’ -> ‘‘Distance Maps’’ -> ‘‘Chamfer Distance Map’’ and click ‘‘Create.’’
25. Click on the CHAMFER DISTANCE MAP module to open the Preference view and adjust the settings

(Figure 7A):
a. Set the interpretation to XY planes.
26. Select the labels object and right click to attach a THINNER module by:
a. either using the search box;

b. or ‘‘Image Processing’’ -> ‘‘Skeletonization’’ -> ‘‘Thinner’’ and click ‘‘Create.’’
27. Click on the THINNER module to open the Preference view and adjust the settings (Figure 7B):
STAR Protocols 1, 100180, December 18, 2020



Figure 9. The WinFiber3D Workspace (Left Side) and the Save File Dialog (Right Side)
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a. Select the [filename].labels object as data source and the [filename].distmap object as Dis-

tmap source.

b. The len of ends parameter (extended options) controls the length of unconnected ends (in

voxel) and thereby control’s the sensitivity to generate branch points. Select a size according

to your data set and the structures of interest. For the sample data, we applied a size of 5

voxel.
28. Click on ‘‘Apply’’ and a [filename].thinned object is created.

Note: The CHAMFER DISTANCE MAP module can process the image slice by slice (Interpretation:

XY planes) or as a whole in 3D (Interpretation: 3D) depending on the application. For our data

set, we used the XY interpretation due to the higher resolution in the x/y plane.
Convert to Spatial Graph and Compute Thickness

Timing: ~30 s per file with Amira

The TRACE LINES module converts the thinned image into a Spatial Graph object in which the data is

organized as a graph. Branch or endpoints are represented by the vertices of the graph (Nodes)

which are connected by curved lines (Segments). This Spatial Graph is then smoothed using a

SMOOTH LINE SET module. The EVAL ON LINES module connects to smoothed skeleton and the distance

map to compute the thickness information of the skeleton.

29. Select the [filename].thinned object and right click to create a TRACE LINES module by:

a. Either using the search box;

b. or ‘‘Image Processing’’ -> ‘‘Skeletonization’’ -> ‘‘Trace Lines’’ and click ‘‘Create.’’

30. Click on the TRACE LINES module to open the Preference view and adjust the settings

(Figure 8A):
STAR Protocols 1, 100180, December 18, 2020 11



Figure 10. A Screenshot of the Expected Output Text File

The first lines present the overall statistics followed by the segment data (left side). Below the segment data, the vessel data can be found (right side).
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a. Tick ‘‘lineset’’ and ‘‘point cloud’’ to compute lines (vessels) and points (branch- and end-
12 S
points).
31. Click on ‘‘Apply’’ and a [filename].Spatial-Graph object is created.

32. Select the [filename].Spatial-Graph object and right click to create a SMOOTH LINE SET module

by:

a. Either using the search box;

b. or ‘‘Compute’’ -> ‘‘Smooth Line Set’’ and click ‘‘Create.’’

33. Click on the SMOOTH LINE SET module to open the Preference view and adjust the settings

(Figure 8B):

a. The smoothing coefficient controls the effect of adjacent points on the position of a point.

Adhere to original data controls the effect of the initial position. For our sample data set

we set a smoothing of 0.5 and adhere to data of 0.25.

34. Click on ‘‘Apply’’ and a ‘‘SmoothTree.Spatialgraph’’ object is created.

35. Select the ‘‘SmoothTree.Spatialgraph’’ object and right click to attach an EVAL ON LINES mod-

ule by:

a. Either using the search box;

b. or ‘‘Compute’’ -> ‘‘Eval on Lines.’’

36. Click on the EVAL ON LINES module to open the Preference view and adjust the settings

(Figure 8C):

a. Data Source: SmoothTree.Spatialgraph.

b. Field: [fielname].distmap object.

37. Click ‘‘Apply.’’
TAR Protocols 1, 100180, December 18, 2020



Figure 11. Troubleshooting the Binarization Step

The image after deconvolution is displayed in the left column. A few faint structures are present in the lowest slice. With the standard binarization

method noise is introduced (middle column), so that the binary image appears fuzzy (middle column, bottom row). Using the histogram calculated for

the complete z stack before thresholding (right column) solves the problem and generates a clear binary image (right column, bottom row).
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38. Select the SmoothTree.Spatialgraph. Export the data ‘‘File’’ -> ‘‘Export Data as’’ and change the

file type to microvisu3D ASCII (.mv3D) (Figure 8D).

a. The mv3d file is a text file containing points specified by a x, y and z coordinate, and number

(the ID of the segment this point belongs to).

Optional: Go to the Filament View to view the output of the Spatial Graph object.
Measurements

Timing: ~30 s per file with WinFiber3D

WinFiber3D is used to visualize the spatial graph data and to export the measurements (Figure 9).

39. Open WinFiber3D and open the mv3D file by
STAR Protocols 1, 100180, December 18, 2020 13
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a. either ‘‘File’’ -> ‘‘Open’’;

b. or Ctrl + O.
40. Export the measurements
a. either ‘‘File’’ -> ‘‘Save’’;

b. or Ctrl + S.

c. The output file is saved as a tab delimited text file. However, the file extension (.txt) needs to

be provided with the file name.

d. Tick ‘‘Statistics’’ to save the measurements of the complete network.

e. Tick ‘‘Segment data’’ to save the orientation data, length, and average diameter of each

segment.

f. Tick ‘‘Vessel data’’ to export the length, volume, and branch points information for each

vessel.

Optional: Loops, segments which start and stop at the same point, can be removed with

‘‘Tools’’ -> ‘‘Delete Loops.’’ The boxes on the right-hand side present the overall statistics

as well as properties of a selected structure. Structures can be removed manually by selecting

them with the mouse and click on ‘‘Delete’’. Various options for rendering the network are

available below the selection box.
EXPECTED OUTCOMES

The output file is a text file containing measurements of the network (Figure 10). The following pa-

rameters are available for the network: total vessel number, total branch points, total end points,

average branch points per vessel, average end points per vessel, total volume of box, total vessel

volume, volume ratio, total vessel length, and average vessel length. Additionally, the orientation

data, length, and average diameter can be determined for each segment. For each vessel, the

length, volume, and number of branch points can be computed.
QUANTIFICATION AND STATISTICAL ANALYSIS

The .txt file can be imported in most of the commonly used data analysis software such as R, Python,

or Excel. The user can select the parameters of interest for further comparison and statistical analysis.
LIMITATIONS

The image analysis protocol is based on manual handling, ‘‘point-and-click,’’ and is therefore not

feasible to use with large sample sizes. However, we have developed Tcl and Python scripts to facil-

itate the automated image analysis. https://github.com/theia-dev/acvq
TROUBLESHOOTING

Problem

If the signal intensity in lower slices (further away from the objective) decreases significantly, noise

can arise during the binarization process (steps 15–18).
Potential Solution

By ticking the ‘‘Use stack histogram’’ option in Fiji, the histogram is calculated for the complete stack

instead of for each slice. This reduces the noise in image with large intensity differences over the z

axis. (Figure 11).
RESOURCE AVAILABILITY

Lead Contact

Further information and requests for resources and reagents should be directed to and will be ful-

filled by the Lead Contact, Laura Bray (laura.bray@qut.edu.au).
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Materials Availability

This study did not generate new unique reagents.

Data and Code Availability

The developed Tcl and Python scripts to facilitate the automated image analysis are available at:

https://github.com/theia-dev/acvq. The supplementary dataset is available at: https://data.

mendeley.com/datasets/btrrwrmt7z/1
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